I really think we should get rid of the gratuitous braces. That could be done
without breaking compatibility, but requires huge modifications to expand.c.

Look how much more readable this is:

> ${reduce
>     ${map ${addresses:$recipients}
>           ${lookup {${domain:$item}}lsearch{/etc/exim/conf/domains}
>                    ${lookup ${local_part:$item} partial0-lsearch              
>                         
>                                         {/etc/exim/conf/${domain:$item}/acls}
>                             ${lookup $value lsearch* 
> {/etc/exim/conf/acls/spam}
>                                      ${extract {reject}{$value}{$value}{0}}
>                                      0}
>                             0}
>                    0}
>           }
>     0
>     ${if >{$item}{$value}{$item}{$value}}
> }

-- 
Magnus Holmgren        [EMAIL PROTECTED]
                       (No Cc of list mail needed, thanks)

  "Exim is better at being younger, whereas sendmail is better for 
   Scrabble (50 point bonus for clearing your rack)" -- Dave Evans

Attachment: pgpmsngbHUerI.pgp
Description: PGP signature

-- 
## List details at http://www.exim.org/mailman/listinfo/exim-dev Exim details 
at http://www.exim.org/ ##

Reply via email to