On Sat, 2003-07-05 at 12:51, Robert Crawford wrote:
> On Saturday 05 July 2003 03:28, James Sparenberg wrote:
> > On Fri, 2003-07-04 at 19:14, John Haywood wrote:
> > > Ive just logged into kde 3.1 (Bamboo 9.1), and for the umpteenth time,
> > > found my menus gone!
> > >
> > > Now, I can fix this by mv .kde .kdeold, then restarting kde, whereupon
> > > the menus reappear, but this is a sledgehammer and nut fix, which
> > > involves resetting all my themes, window decorations, datafiles, moving
> > > or recreating the resource and config files in .kde/share and config etc
> > > etc. Not to mention that my home directory is getting a bit littered with
> > > kdeold, kdeoldest, kdestuffed etc etc
> > >
> > > Now, can anyone point me to the file (s) which might be causing this?.
> > > As previously posted, I get the same result if I try editing the menu
> > > using menudrake, either as user or root, either the Sys menus or the User
> > > menus. Both same - menus well and truly edited!!!
> > >
> > > There must be a file or combo in ~/.kde which is, or becomes corrupt
> > >
> > > All ideas welcome!!!
> >
> > Does update-menus run as the user bring them back?
> >
> > James
> 
> I seem to recall when this was happening to me, there was a kde config file 
> that kept getting overwritten somehow- if I think of it, I'll post, but 
> really the fix seems to be upgrade to Tex's stuff. I've not had one problem 
> like that since I did. I think people (me included) went back and forth on 
> pclinux online about this, so probably those threads are still there if 
> you're interested.
> 
> James- that update-menus trick worked for me a few times, but it always 
> reverted to the overwritten file. I'm trying to recall exactly what action 
> instigated this, but at present, it escapes me.
> 
> Robert Crawford

Robert

   Now that you mention it.. I'm on Texstar's rpms myself as well.  Have
been since about 3 days after 9.1 came out.  In fact 3.1.2 runs like a
top on my box.  While I check things out locally.. I've one question for
John on his box.  Has he done upgrades at all.  Thought here is that I
know kdmrc (/usr/share/config/kdm/) has changed.  If the new one is
still there as kdmrc.rpmnew moving this to kdmrc will help a number of
things (this file did change.) and I remember it causing me a plethora
of problems till I did this.  Now the menu is assembled from the
structure in  ~/.kde/share/applnk-mdk.  Is this directory structure
present?

James



Want to buy your Pack or Services from MandrakeSoft? 
Go to http://www.mandrakestore.com

Reply via email to