On Wednesday 19 November 2003 05:42 pm, Dick Gevers wrote:

> There`s easier ways to tackle that; IMHO. Proberbly failsafe is safe, but
> why bother, if you`re careful and consider beforehand what you do, go to
> init 1 and cd to where you want to make your changes. Of course, vi may be
> the preferred editor for that, but I didn`t have the time to learn it yet.
> Still mc has a pretty easy editor which will easily access what you need to
> change.

Well, at the point that the machine hard locks, keyboard doesn't respond, 
can't SSH into it and it becomes an effective doorstop, there is not much 
else to do but restart the machine and remove the lm_sensors script from the 
init process to troubleshoot the problem which is effectively what I did.  

When manually loading, it still causes the hard lock, again, no choice but to 
powercycle the machine which involves rebooting.

> I would follow following scenario: a. make sure sensorsd service is not
> running. b. Run the script provided, don`t allow it to modify your
> conf.modules or whichever they suggest. You already know which modules the
> script found, so check no modules are loaded, and if they that they are not
> added by modules.conf. If no modules are listed in the output of lsmod
> continue, if they are start service lm_sensors and with, for instance
> Gkrellm see if you get any readings. That means the kernel gives them
> direct. Only those modules which the kernel might not provide data output
> for should be loaded as modules via modules.conf. Before any adjustment to
> the modules stop the service and restart after added (or removing) any
> modules which do not show up useful values.

I tried manually loading an unloading one at a time but I might not have done 
it often enough to get the hard lock.  Now it appears that the culprit is 
linked to one of the modules and since removing it, I no longer have the 

> Compare your kernel logs, particularly /var/log/kernel/errors. It will show
> bus collisions, if any. I was lucky I did not get hard locks when I ran too
> many modules, but the logs filled alright.

Well, all I got was hard locks and there was nothing in the logs to show what 
was causing it.  I checked and there is nothing from the start until it shows 
the hard reboot with kernel reloading.

> >I have just edited my modules file to load the i2c-proc module at bootup
> >rather than letting it load from the lmsensors init script.  If anyone has
> >any suggestions for me, I would really appreciate it.
> So you appear to be infected by the reboot philosophy of certain O/S`s
> (sometimes I am guilty of similar behaviours to analyze prob ;-), but with
> this (unless hardlocked), I see no need to reboot.

Since the only issue that I spoke of was the hardlock, not sure I follow your 
analysis about my troubleshooting style.  I don't reboot my machine on a whim 
and certainly know how to init 1 and then back to init 3 if all I wanted was 
to test the init process.  

> >BTW, sensors.conf is stock and I did not add any lines to
> > /etc/modules.conf
> You should, that is the only way for the service which this package
> provides will read any data that are not provided by the kernel. Unless,
> naturally, the kernel provides *all* for your particular mobo.

Well, I will probably have to edit that eventually to get the temps for Vcore 
accurately reported but the stock conf file appears to be doing a great job 
so far on CPU temp, MB temp and fan speed.
Bryan Phinney
Software Test Engineer

Want to buy your Pack or Services from MandrakeSoft? 
Go to http://www.mandrakestore.com

Reply via email to