i was on vacation so I missed this. sorry for the trouble and thanks for
fixing the test. This test was fixed once before
.  I've no idea why only this test needs to have the "-flags +bitexact
-idct simple" while the other tests are fine.  I've used the same file as
the other tests, but just changed the Entry count atom using an Atom editor.

On Tue, Dec 5, 2017 at 4:12 PM, Michael Niedermayer <mich...@niedermayer.cc>

> On Tue, Dec 05, 2017 at 08:17:14PM +0000, Derek Buitenhuis wrote:
> > >> The commit that broke it should be reverted until the author
> > >> of that commit can explain why it changed, or fix it.
> > >
> > > The commit that added the test was the one that broke fate. It never
> > > worked.
> > > So this "sort of" reverts what caused the issue.
> >
> > Wasn't the code it tests added directly before the commit that added this
> > test? That's the code that is broken.
> >
> > The way I see it, the code is  workaround for broken files, but it
> doesn't
> > actually work. It should either be fixed, or the workaround removed if
> > nobody (especially the author) is willing to fix it.
> The test produces different output on qemu arm and x86-64.
> From this we know there is a bug, but not where the bug is.
> It can be in the test, the newly added code tested or code that was
> there before.
> My guess was, its the test, i cannot logically explain why.
> ive looked into this now and its missing -idct, adding that makes it
> produce the same result here
> ill push a fix for this
> thanks
> [...]
> --
> Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
> There will always be a question for which you do not know the correct
> answer.
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel@ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
ffmpeg-devel mailing list

Reply via email to