Andreas Hummel wrote:
Hello Kevin, thanks for the hint. I replaced the -colormatrix option
with the -vf scale=.. option you suggested but i'm still getting a
slight hue shift in the final converted movie.

Even the added -sws_flags you suggested thx @Andy couldn't solve the
 problem. I tried various combinations but somehow i can't get a
color correct output with ffmpeg so far.

ffmpeg.exe -loglevel verbose -y -f image2 -start_number 0 -r 25 -i
INPUT -r 25 -vcodec prores_ks -profile:v 3 -pix_fmt yuv422p10le -vf

-sws_flags accurate_rnd+full_chroma_int+full_chroma_inp+bitexact
-color_primaries bt709 -color_trc bt709 -colorspace bt709 -vendor

[Parsed_scale_0 @ 00000000025899a0] w:iw h:ih flags:'bicubic'
interl:0 [graph 0 input from stream 0:0 @ 0000000002587ba0] w:1920
h:1080 pixfmt:gbrp10le tb:1/25 fr:25/1 sar:1/1 sws_param:flags=2
[graph 0 input from stream 0:0 @ 0000000002587ba0] TB:0.040000
FRAME_RATE:25.000000 SAMPLE_RATE:nan [Parsed_scale_0 @
00000000025899a0] w:1920 h:1080 fmt:gbrp10le sar:1/1 -> w:1920
h:1080 fmt:yuv422p10le sar:1/1 flags:0x4

I can see from that that the -sws_flags didn't take.

I don't have your input and like Carl Eugen said the upload site is so
annoying I haven't seen your output either. Even if I had I don't know
how it was made or how good any 10 -> 8 bit conversion was, plus I would
be viewing on a crappy tn panel which likely doesn't even do 8 bit.

I did a test with some 48 bit rgb sgi images

In summary rather than -sws_flags appending below to the scale command


got a different output for me. I don't know how you would test 10 bit
though as making/displaying jpg involves another conversion, which may
give different output depending on what/what parameters are involved.
ffmpeg-user mailing list

To unsubscribe, visit link above, or email with subject "unsubscribe".

Reply via email to