My experience was I needed to update to MacOS 10.12 (Sierra) before Xcode 8 had 
the new set of Command Line Tools.
(you may need to reinstall Xcode 8 after OS update, but I am not sure.  I tried 
to open bug with Apple for allowing upgrade to Xcode 8 on El Capitan without a 
warning about the CLTs)

jw

> On Oct 9, 2016, at 12:54 PM, Marc Boxerman <mboxer...@mac.com> wrote:
> 
> Thanks, Alex.
> 
> Perhaps I jumped the gun.  When updating a package, Fink warned of the 
> version mismatch and advised that compile errors could result.  Some packages 
> built.  Others failed.  I recall encountering a problem updating an 
> imagemagick library. and another package or two.  But I updated Fink itself, 
> which looks to have removed that warning, and I’ve been able to compile at 
> least some of the packages whose build previously failed.  I believe the only 
> package I cannot update now is openmpi.
> 
> Marc
> 
>> On Oct 8, 2016, at 3:18 PM, Alexander Hansen <alexanderk.han...@gmail.com> 
>> wrote:
>> 
>> 
>>> On Oct 8, 2016, at 10:37, Marc Boxerman <mboxer...@mac.com> wrote:
>>> 
>>> I upgraded to Xcode 8 on a machine running El Capitan.  It does not appear 
>>> that Apple released an updated set of command line tools for the newest 
>>> version of Xcode, at least not for OS X 10.11.  The mismatch in versions 
>>> between Xcode and the command line tools is causing build failures.  Should 
>>> I downgrade to Xcode 7 or is there a newer version of command line tools 
>>> out there?
>>> 
>>> Thanks,
>>> 
>>> Marc
>> 
>> 
>> My understanding is that the official position from Apple is that Xcode 8 + 
>> the Xcode 7.3.1 command tools should work.  
>> 
>> If you could report the build failures here, (different threads for each 
>> package, please) we should be able to fix the issues.  And if your version 
>> of “fink-package-precedence” isn’t up-to-date, that may be indirectly 
>> responsible for some of the issues—Apple changed the behavior of the “otool” 
>> executable.  But we’d definitely appreciate any bug reports before you 
>> update fink-package-precedence and/or downgrade Xcode. :-)
>> 
>> 
>> 
>> 
>> 
>> 
> 
> 
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most 
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
> _______________________________________________
> Fink-beginners mailing list
> Fink-beginners@lists.sourceforge.net
> List archive:
> http://news.gmane.org/gmane.os.apple.fink.beginners
> Subscription management:
> https://lists.sourceforge.net/lists/listinfo/fink-beginners


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Fink-beginners mailing list
Fink-beginners@lists.sourceforge.net
List archive:
http://news.gmane.org/gmane.os.apple.fink.beginners
Subscription management:
https://lists.sourceforge.net/lists/listinfo/fink-beginners

Reply via email to