As others have said, consistency is more important, but that's not to say
that there are no good or bad naming conventions.

Five years ago I had stupidly small names, then stupidly long names, now
they're somewhere in the middle and mostly sensible and readable :O)

Also, if you're working on a project with others, be consistent with each
other. If it's a fresh project, have a chat about what to use. If you're
coming on board you might be more inclined to follow what's already there.

Have a play about, see what you prefer. Just try not to change midway
through a project!

Adrian

-----Original Message-----
From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] Behalf Of Stephen
Ford
Sent: 02 February 2006 01:53
To: flashcoders@chattyfig.figleaf.com
Subject: [Flashcoders] Naming conventions for AS2.0 ...



Does anyone have an opinion, or a preferred method, in regards to
naming conventions for AS2.0 objects ?

For example, Macromedia recommends:

clip_mc (movie clip)
comm_lc (local connection)
names_array (array)
beep_sound (sound)
field_txt (text field)
etc, etc, etc

but what if I wanted to use an generic object or a boolean datatype:

listener_???:Object = new Object();
answer_???:Boolean = false;

These are just two datatypes Macromedia doesn't list in terms of
suffixes (search for 'About using suffixes to trigger code hints' in the
official Flash help documentation built into Flash).

So another technique I have seen is prefixing variables, like:

mcClip (movie clip)
lcComm (local connection)
aNames (array)
etc, etc, etc

Someone must have a foolproof way to do this, there must be
a technique that covers all possibilities for naming variables ???

Thanks,
Stephen.

_______________________________________________
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders

Reply via email to