Hello Björn,

On 20.02.2018 12:57, Björn Tantau wrote:
> Hi!
> 
> I tried to flash a new BIOS to my AOpen i965GMt-LA motherboard. Reading
> the ROM worked, but flashing did not. I'll gladly give you more
> information, just tell me what you need. :-)

boards of that generation often have a write-protection pin of the flash
chip asserted (often only to prevent accidentally writing to the flash).
There is no standard for this, so that pin could be connected to any-
thing, e.g. a jumper on the board, a GPIO of another chip (maybe con-
trolled by a BIOS setup option or by the vendor flash application). In
the latter case, flashrom would need something we call a board-enable
procedure to toggle the GPIO.

Please consult your board's documentation for anything flash related.
If you can't find something, you can try to find the board's schematics
to figure out if there's a write-protection pin and where it is connec-
ted to. Reverse engineering the vendor's flashing tool would also work.

Nico

_______________________________________________
flashrom mailing list
flashrom@flashrom.org
https://mail.coreboot.org/mailman/listinfo/flashrom

Reply via email to