Hi,

 

I have been struggling with Authentication of the remote object service on Websphere 6.0. This is the first time I am doing this configuration so not sure what I am doing wrong. I will list what steps I did so far.

 

-- Flex-config.xml

 

<named>

  <object name="responsibilityAssignmentDelegate">

    <source>com.software.ResponsibilityAssignmentDelegate</source>

    <type>stateless-class</type>

                                    <use-custom-authentication>true</use-custom-authentication>

    <allow-unnamed-access>false</allow-unnamed-access>

                                    <roles>

            <role>admin</role>

    </roles>

  </object>

</named>

 

 

-- Web.xml

 

    <security-constraint>

            <display-name>Test1</display-name>

            <web-resource-collection>

                        <web-resource-name>Protected Page</web-resource-name>

                        <description>Test with J2EE</description>

                        <url-pattern>/amfgateway/responsibilityAssignmentDelegate</url-pattern>

                        <http-method>GET</http-method>

                        <http-method>POST</http-method>

            </web-resource-collection>

            <auth-constraint>

                        <description>admin</description>

                        <role-name>Admin</role-name>

            </auth-constraint>

    </security-constraint>

    <security-role>

            <description>admin</description>

            <role-name>Admin</role-name>

    </security-role>

 

In Websphere I am using custom user registry and Global Authentication is enabled. I can login to Websphere Admin Console using my user/pwd, but can’t get authenticated if I try from flex login.

 

Thank you,

 

Shahn



Yahoo! Groups Links

Reply via email to