On Wed, 01 Sep 2004 11:54:08 -0700
 Alex Romosan <[EMAIL PROTECTED]> wrote:

you need to have the expat library installed (+ the header files) but
then you can use just easyxml.cxx from simgear with the following
patch applied:

--- easyxml.cxx 29 Jul 2004 08:30:10 -0000 1.4
+++ easyxml.cxx 1 Sep 2004 18:49:57 -0000
@@ -5,7 +5,7 @@
#include <string.h> // strcmp()
#include "easyxml.hxx"
-#include "xmlparse.h"
+#include <expat.h>
#include STL_FSTREAM
#include STL_IOSTREAM


i've been running simgear like this forever (the rest of the files in
simgear/xml are a rather old version of the expat library).

Thanks. I was able to compile three xml***.c files early today (in the lib/ directory of the eXpat dist). I don't know if that is the eXtent of what is required to compile EasyXML or not, yet. Also, somehow I have to figure out how to get JSBSim to compile with a new class (FGXMLParse) that uses easyxml (which in turn uses eXpat) for the standalone version of JSBSim, and also compiles and links within FlightGear. That shouldn't be too big of a deal, but it could be tricky.


Jon

_______________________________________________
Flightgear-devel mailing list
[EMAIL PROTECTED]
http://mail.flightgear.org/mailman/listinfo/flightgear-devel
2f585eeea02e2c79d7b1d8c4963bae2d

Reply via email to