On Saturday, 26 February 2005 13:07, Paul Surgeon wrote:
> On Saturday, 26 February 2005 10:51, Erik Hofman wrote:
> > The annoying click is because the audio file is not edited correctly.
>
> This one has me a bit stumped.
> It loops without clicks in Audacity and I've check the individual samples
> and the start/end joint is perfect.
> Do samples have to start and end with a sample value of zero in order to
> not click?
> I'll try to figure this one out.

This looks like an OpenAL problem or maybe a problem with the FG 
implementation.
All the looping sounds in FG "click" however they are barely noticable because 
the sounds that are played are very "noisy" for lack of a better description.

If you use a clean signal such as a sine wave with no other ambient sounds you 
immediately hear the clicking.

It has nothing to do with the audio file as far as I can see.
Here is my audio file :
http://surgdom.hollosite.com/flightgear/tmp/sink-tone.wav

Here is what the join looks like when I copy the beginning of the sample and 
paste it on the end :
http://surgdom.hollosite.com/flightgear/tmp/wavmatch.png

If someone can point out where the click is coming from I'd appreciate it but 
as I said in my previous e-mail the sound loops perfectly in Audacity with 
zero "clicks".

Regards
Paul

_______________________________________________
Flightgear-devel mailing list
Flightgear-devel@flightgear.org
http://mail.flightgear.org/mailman/listinfo/flightgear-devel
2f585eeea02e2c79d7b1d8c4963bae2d

Reply via email to