Lee Elliott wrote:
On Thursday 26 May 2005 19:56, Lee Elliott wrote:

On Thursday 26 May 2005 02:50, Geoff Reidy wrote:

Lee Elliott wrote:

I'm having a strange problem that may be linked to this.

Now when I start at KSFO, looking forward, I'm getting <
1fps. Same with the heli & chase views.  If I switch to
the tower it's the same until I start zooming in.  At
around 15 deg fov the frame rate jumps up to around 25-30
fps.  Switch back to the chase view and it's back down to
< 1 fps.

Incidentally, the a/c I'm checking with has slowly
revolving props so I can see the changes in frame rate
very clearly.

Anyway, back to the chase view and rotate the view around
using shift and the num-pad.  Shift-9 is fine - > 20 fps,
shift-6 < 1 fps, shift-3 > 20 fps.  From 2 through to 8
are all < 1 fps.

Try KJFK.  Here only one view gives problems (can't
remember exactly which one now though).  It's also
apparent while using the mouse to change the view.

Back to KSFO, tower view and try a take off - > 20 fps. Try chase view and < 1 fps until just after the last of
the white blocks on the runway (sorry, don't know their
proper name) when it jumps to > 20 fps.

It'll also happen while I'm flying - I flew out over
downtown SFO and was heading back to KSFO at > 20 fps but
then it dropped back down to < 1fps.

I'm guessing that it's due to a scenery or random object
problem, as it also happened at KJFK where there're no
custom scenery objects, but I can't identify what it can

Any ideas anyone?  FG is pretty unusable for me atm.

FWIW, glxgears gives > 3900 fps here.


I get this problem also with any of the Nvidia Linux 7xxx
drivers. Other programs like torcs still run fine, only fgfs
seems to be affected.

I used to get 30 to 40 fps at KSFO. If I look down at the
cockpit (still at KSFO) or up at the sky or I look to the
right more than about 15 degrees or to the left at about 90
degrees it runs at normal speed. Look straight ahead and I
get about 1 frame every five seconds. Same result at KEMT.

Have looked through the nvidia forums but haven't seen
anyone complain of problems like this.


Thanks for that Geoff.  I've already got a couple of older
drivers and I believe that all the old drivers can still be
downloaded from the archive at nVidia.

I'll give it a go here and report back.


I have three version here 7174, 7167 & 6629. Both of the 7nnn exhibit the same problem and 6629 won't compile here. Drat!

Which kernel version are you using?  I'm on 2.6.11 here.


2.6.11 and also can't build the older drivers, as I since found out :(
Just updated from 2.6.9 where only <= 6629 worked properly with fgfs.
Debian unstable.


Flightgear-devel mailing list

Reply via email to