On 04/08/13 15:50, Greg Ercolano wrote: > On 04/08/13 15:32, Albrecht Schlosser wrote: >> On 06.04.2013 07:55, Greg Ercolano wrote: >> BTW: toplevel_window() doesn't look bad, but what about top_window(). >> Less typing ;-) > > Yes, what I based 'toplevel_window()' on was that in our code, > the term 'top-level' is used fairly consistently to refer to > the real window in a widget hierarchy. > > This, as opposed to 'top' as perhaps meaning the window on "top" > of all others in window depth (along the Z axis) > > I have no real preference otherwise.
While writing a test program, I see the point of 'top_window()' being easier to write, and kinda seems more consistent with FLTK's short names for methods. So I'm +1 for top_window() instead of toplevel_window(). _______________________________________________ fltk-dev mailing list fltk-dev@easysw.com http://lists.easysw.com/mailman/listinfo/fltk-dev