Hi Runar,

Are you using a relative url to reference the image? Remember that Fop will
use the current dir of the servlet engine's VM, not the directory of your
source fo. This will not generate an exception, but a warning (I believe) -
does the system.out log have anything to say for itself? Or is Fop's message
generation set to NONE?

HTH,
JT

-----Original Message-----
From: Runar Bjarnason [mailto:[EMAIL PROTECTED]]
Sent: Thursday, August 02, 2001 11:55 AM
To: '[EMAIL PROTECTED]'
Subject: images from a servlet?


Hi.

I'm able to get images in my pdf output when running fop from the command
line, but when I embed it in a servlet (used the example in the FAQ), no
images appear. There is no exception or anything like that. The images
simply don't show up. Is there any known issue with certain JVMs or
something that might be causing images not to appear? I'm running WebSphere
3.5 with Java 1.2.2. The FO file I'm trying is the images.fo from the
examples dir.

By the way, is there an effort underway to make a FOP API that conforms to
Java 1.2 and the new J2EE 1.3 javax.xml packages? I find the current
architecture rather inflexible (procedural programming practices abounds).

Thanks,
Runar


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to