On Wednesday, August 8, 2001, Alex McLintock <[EMAIL PROTECTED]> wrote:

> ... but now I have a problem with a particular build of IE. Basically 
> the PDF doesn't appear -
> in fact neither does acrobat reader....
> The problem occurs on the IE version 5.50.4522.1800 and not with other 
> IE5.5 versions, eg.
> 5.50.4134.0600.
> (Incidently the data is submitted to the servlet using Post - 
> apparently this is
> the cause of the bug in IE)

Not sure what bug you are talking about here, but I don't
think your problem is associated with doPost().

> [...]

> So folks - what are your servlet experiences....?

We don't serve up PDF via FOP (yet) but we do let users download
PDFs which we have just cranked out by some other rickety process.
This worked quite well for several years, when all of a sudden, it
didn't.  We first isolated the problem to both MSIE 5.50.4522.1800
and oddly enough, NS 6.0, both on Win2k systems.

Weblogic was showing a socket exception error message in
the command console window.  We tried all the usual server side
tricks (e.g., res.setContentLength(), and so on), but they had no

We hunted everywhere for an explanation, and essentially
found none.  Posting to various newsgroups led no where.
However, while I was stumbling around on Microsoft's site, I
somehow wound up on their updates page, and noticed that
I hadn't updated much in the last however many months.  One
of the first things I updated was second or third release of
patches to MSIE  5.50.4522.1800.  I believe it was the Q299618
patch that restored the ability to download using MSIE 5.50.4522.1800.
Currently, the "About MSIE" (or whatever it's called in the Windows
version) lists the following updates:

      SP1; Q286043; Q299618

Note that this latest patch appeared on MS's "Critical Updates" page.

Also note, MSIE on MacOS X never showed this problem.  Neither did
OmniGroup's OmniWeb for MacOS X.

Paul Furbacher

To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to