+1 in general to move away from InputHandler to JAXP, but please not
this way! This is a performance and memory usage nightmare.
Don't buffer the intermediate result. Please use SAX to pipe the XSLT
output directly over to FOP. Even better, get rid of InputHandler
alltogether and work with JAXP full-time. And please remember
backwards-compatibility in the apps package (deprecate InputHandler,
don't delete).

Use transformerFactory.newTransformer() [identity transform] when no
stylesheet is specified and transformerFactory.newTransformer(new
StreamSource....) when there is a stylesheet. There is almost no
performance penalty between using a SAXParser and the identity
transformer but it makes the code easier to read.

If you need examples, please see the ones in examples/embedding.

Thanks!

On 21.07.2003 17:24:53 Glen Mazza wrote:
> For internal xml/xslt -> fo translation,  we are
> currently using XSLTInputHandler in three places:
> CommandLineOptions, FopPrintServlet and
> TestConverter.java.  (TraxInputHandler isn't being
> used internally.)  I would like us to switch from
> XSLTInputHandler to JAXP.
> 
> For CommandLineOptions, I am thinking of converting
> the getInputHandler() to always return an
> FOInputHandler() as follows:

<rest snipped>



Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to