FOP's minimum requirements[1]:

System Requirements

The following software must be installed:
â Java 1.2.x or later Runtime Environment.
â FOP. The FOP distribution includes all libraries that you will need to run a basic FOP installation. These can be found in the xml-fop/lib directory. These libraries include the following:
â Apache Xerces-J for XML parsing. You can use other XML parsers which support SAX and DOM.
â Apache Xalan-J, an XSLT processor.
â Apache Batik, an SVG library.

However, according to J.Pietschmann[2]:

Chris Bowditch wrote:
> I did a quick search of the archives and found the thread that decrees
> 1.1 will no longer be supported and the minimum JDK is 1.2.

Acutually I doubt FOP 0.20.5 will run completely in an 1.2 environment.
The binary is compiled with 1.4.1, and I vaguely remember compiling
problems already for 0.20.4 on 1.2.


It would be nice to *know* (and post on our site) the "real" requirements for running FOP. If there are different minimum requirements for fop-20.4 and fop-0.20.5, this information should be on the FOP site. fop-users looking to fill their needs shouldn't have to download the latest version only to find it doesn't work under their lowly JRE.

Web Maestro Clay

p.s. On second thought, maybe that'll be something I'll figure out myself (although it would be better if the legwork were already done! :-D)



Reply via email to