--- [EMAIL PROTECTED] wrote:
>        
>   -    protected void startPart(BlockSequence list)
> {
>   +    protected void startPart(BlockSequence list,
> int localPageNumber) {

"boolean isFirstPageByBlock" is probably better.

The meaning of "localPageNumber" to indicate the first
page created by a particular block I think will cause
confusion, especially when read within PSLM.  Also,
since the logic only cares about whether or not the
page is the *first* page being rendered by the block,
a boolean would appear to better capture the usage of
this variable.


>            //nop
>        }
>        
>   @@ -202,7 +202,7 @@
>                System.out.println("PLM> part: " + (p
> + 1)
>                        + ", break at position " +
> endElementIndex);
>    
>   -            startPart(effectiveList);
>   +            startPart(effectiveList, p+1);
>                

startPart(effectiveList, (p==0)? true:false);

Glen

Reply via email to