On Sat, 19 Nov 2005 05:20 am, Simon Pepping wrote:
> On Fri, Nov 18, 2005 at 09:39:03PM +0100, J.Pietschmann wrote:
<snip/>
> > BTW. Ant 1.6.1 complains: build.xml:808: The <fail> type doesn't
> > support the nested "condition" element.
> > Do we really need a bleeding edge ant? (although the Ant people
> > could be a bit less aggressive with adding features in minor
> > releases too).
>
> The else attribute of the condition element (line 1046) requires Ant
> 1.6.3. Well, I upgraded.
>
Sorry that was me - no intention to be bleeding edge - just looked at 
the ant documentation to see how I could do what I wanted and that 
feature seemed appropriate. Must admit never occurred to me to check 
when it was introduced into ant.

If someone knows how to achieve the same or similar outcome with an 
older version of ant - I would say just go for it and fix build.xml.

> Simon

Manuel

Reply via email to