Hi All!

I am having an enormous problematic time trying to get
fo:marker and fo:retrieve-marker to work correctly in
some tables that continued to a second page. I have
reviewed several examples and it still doesn’t click.
Maybe too much holiday time off! 

The "(Continued)" text is displaying on the first
occurrence of the table title as well as the second.
It should only be displayed on the second occurrence.
I have included the XSL snippet below.

I really appreciate any help in you can offer. Thanks
in advance for your help! 

S.E.


<fo:flow  flow-name="xsl-region-body"
font-family="Arial">
  <fo:block>
  <fo:marker marker-class-name="cont">
    <fo:inline>(Continued)</fo:inline>
  </fo:marker>
</fo:block>
...
</fo:flow>

<fo:table-and-caption space-before="2em">
<fo:table table-layout="fixed" width="100%">
<fo:table-header>
<fo:table-row>
<fo:table-cell border-style="solid"
border-width="1.5pt"  border-bottom="1.5pt"
border-left="1.5pt"  
border-right="1.5pt" padding-top="1pt"
padding-bottom="1pt" font-size="24pt"
text-align="center" 
number-columns-spanned="7">
<fo:block font-weight="bold">
<xsl:value-of select="title"/>
</fo:block><!--Section 4 Title -->

<fo:block line-height="0pt">
<fo:retrieve-marker
retrieve-position="last-starting-within-page"
retrieve-class-name="cont"/>
</fo:block>

</fo:table-cell>
</fo:table-row>
</fo:table-header>
...
</fo:table>


                
__________________________________________ 
Yahoo! DSL – Something to write home about. 
Just $16.99/mo. or less. 
dsl.yahoo.com 

Reply via email to