Andreas L Delmelle wrote:

On Aug 23, 2006, at 20:16, Patrick Paul wrote:

<snip />
You are right. Thanks for the suggestion. I would even say that "determine" is misleading since the min and max content widths are calculated when getNextKnuthElements is called. So it maybe it would be better to name it getMinMaxContentWidth() ?

That would be fine, if the method's return type reflects this.

It returns an object that I called MinMax. This object has to accessors: int getMin() and int getMax().

Maybe I shouldn't be calculating the min and max content widths while element creation is done ?

Not sure what you mean here: the elements need to be created to be able to determine how large your minimum-width is, so your min/max calculation needs to be performed in between the element creation and the start of the actual breaking...

Yes I agree. I am actually doing this WHILE the elements are being created. Maybe this in an incorect way of doing things ? I will soon be sending a little patch using this getMinMaxContentWidth() method. No more static variable, hehehe ! So you will see what I mean.



Thank you,


Reply via email to