I agree that it should be fixed, but, for now, I'm happy to have a work-around, so that I can proceed.

Thanks, Jeremias.

Jay Bryant
Bryant Communication Services

----- Original Message ----- From: "Jeremias Maerki" <[EMAIL PROTECTED]>
To: <fop-dev@xmlgraphics.apache.org>
Sent: Wednesday, March 14, 2007 11:14 AM
Subject: Re: XMLUnit causing error

Indeed, I can reproduce that. What I've done on my machine is a
build-local.properties text file in FOP's root directory with the
following content:

optional.lib.dir = C:\\Dev\\FOP\\optional-lib
javahome.jdk14 = C:\\Dev\\J2SE\\1.4.2_10
junit.haltonfailure = on

I've put the xmlunit JAR file in the optional-lib directory. In that
case, it works. I guess we should still try to fix the problem. The
reason is probably the use of a classpath element in the junit tasks.

On 14.03.2007 16:54:08 Jay Bryant wrote:
Hi, folks,

In the course of testing the named destination code, I ran over the
following error (in the IntermediateFormatTestSuite):

java.lang.reflect.InvocationTargetExceptionCaused by:
java.lang.NoClassDefFoundError: org/custommonkey/xmlunit/XMLTestCase at...

That didn't look like anything I had done, so I downloaded a fresh copy of
the trunk and tested it without any modifications. I got the same error.

I have a copy of xmlunit.jar in ant's lib directory, and I get "XMLUnit
Support PRESENT" when I run the junit target. ALso, I checked the contents
of xmlunit.jar and found XMLTestCase.class.

So, what do I do about this issue so that I can get an error-free run of the
junit tests and then commit the named destination code?


Jay Bryant
Bryant Communication Services

Jeremias Maerki

Reply via email to