Frankly, I'm less than thrilled. I appreciate the good will behind this
but I'd have appreciated some advance warning, too. My concern is that:
-        ListElement last = (ListElement)contentList.getLast(); 

is much easier to read and write than:

+        ListElement last = (ListElement) contentList
+                .get(contentList.size() - 1); 

When working with element lists constructs like the above are everywhere.
A linked list IS the most efficient data structure for element lists. I
generally support using the generic type instead of the specific class
(i.e. List instead of ArrayList), but LinkedList is adding some often
used methods for element lists which improve code readability. I'm
curious what other committers think about this.

On 09.06.2008 16:25:29 Adrian Cumiskey wrote:
> This is really good Max, really appreciate what you are trying to do here.  
> It must have been quite 
> boring and laborious...  but great cleanup work :).
> 
> [EMAIL PROTECTED] wrote:
> > Author: maxberger
> > Date: Mon Jun  9 07:15:38 2008
> > New Revision: 665699
> > 
> > URL: http://svn.apache.org/viewvc?rev=665699&view=rev
> > Log:
> > Replaced LinkedList with generic List interface
> > 
<snip/>

Jeremias Maerki

Reply via email to