Well, I removed the jeuclid libraries and apache fop compiled the document
but threw up some errors. One of those errors concerned an incorrectly
specified path to a system directory containing images. The drive
specification was missing from an uri of the form file:///... I added the
drive specification (file:///C:/...) and this error was fixed. There were
lots of font warnings and most of the symbols in the document are currently
represented by a hash, but I have ignored that for the moment as a separate
issue to fix.

I then put the jeuclid libraries back... and low and behold, I am no longer
able to reproduce the crash I was having before. I have also tried a
document containing mathml, and even though there are other problems with
it, the mathml is rendering just file.

So, it appears to have been a false alarm, or, at least, apache fop wasn't
correctly catching some file specification error and providing a sensible
error message.

Cheers, Paul

Max Berger wrote:
> Paul,
> due to changes in the ImageLoader API you have to use matching version
> of JEuclid for FOP to work.
> I tried to reproduce your error and I was unable to reproduce it using
> FOP trunk and JEuclid 3.1.3.
> Also, in the .fo given:
> http://www.nabble.com/file/p20339979/doc.xml.fo
> There is no MathML used.
> If this is the file you're having trouble with:
> - delete (temporary) the jeuclid libs and see if that helps. If so, I
> need to fix this in JEuclid [ I'll then ask for more information ].
> - if that did not change anything it's a bug in fop. In this case,
> please make the PNG files available, maybe there error lies therein?
> Max

View this message in context: 
Sent from the FOP - Dev mailing list archive at Nabble.com.

Reply via email to