Hi Georg,

You can usually forget about the warnings, as long as you don’t have the
message “Test org.apache.fop.layoutengine.LayoutEngineTestSuite FAILED”
at the end of the output.
Try generating PDF out of the failing testcases and visually check
what’s wrong; simply run the following command in the test/layoutengine
directory:
fop -xsl testcase2fo.xsl -xml standard-testcases/{failing-test}.xml -pdf out.pdf

That may help you figure out what’s wrong. You can also run the debugger
side by side, on both a non-modified version of the Trunk and the
version with your changes, and see where it starts to diverge.

If you’re stuck you can always attach an updated patch on Bugzilla, so
that we can have a look at it.

Good luck,
Vincent


Georg Datterl wrote:
Hi Vincent,

given the fact that nobody else reads our thread, fox:disable-column-balancing 
it is and I think I made all suggested changes. Now I'm trying to build a 
testcase and then move on to the next needed extension. I'm running ant target 
juni-layout-standard but get lots of error messages and warnings from all kinds 
of tests (Junit and xmlunit are present):

Test: block_font-style.xml
  [ERROR] Invalid property value encountered in font-style="obscure": 
org.apache.fop.fo.expr.PropertyException: No conversion defined obscure; 
property:'font-style' (Keine Kontextinformationen verfügbar)
  [ERROR] Invalid property value encountered in font-style="obscure": 
org.apache.fop.fo.expr.PropertyException: No conversion defined obscure; 
property:'font-style' (Keine Kontextinformationen verfügbar)
  [ERROR] Invalid property value encountered in font-style="obscure": 
org.apache.fop.fo.expr.PropertyException: No conversion defined obscure; 
property:'font-style' (Keine Kontextinformationen verfügbar)
  [WARN ] Font "serif,backslant,400" not found. Substituting with 
"serif,normal,400".
  [WARN ] Font "sans-serif,backslant,400" not found. Substituting with 
"sans-serif,normal,400".
  [WARN ] Font "monospace,backslant,400" not found. Substituting with 
"monospace,normal,400".

...

Test: table_table-row_empty.xml
  [INFO ] table-layout="fixed" and width="auto", but auto-layout not supported => 
assuming width="100%". (Keine Kontextinformationen verfügbar)
------------- ---------------- ---------------
------------- Standard Error -----------------
09.01.2009 10:18:33 org.apache.fop.layoutengine.LayoutEngineTestSuite$1 runTest
SCHWERWIEGEND: Error on block-container_absolute-position_multi-column.xml
09.01.2009 10:18:36 org.apache.fop.layoutengine.LayoutEngineTestSuite$1 runTest
SCHWERWIEGEND: Error on block-container_reference-orientation_bug36391.xml
09.01.2009 10:18:47 org.apache.fop.util.ColorSpaceCache get
WARNUNG: Color profile 'nonexistent.icc' not found.
09.01.2009 10:18:47 org.apache.fop.util.ColorUtil parseAsFopRgbIcc
WARNUNG: Color profile 'nonexistent.icc' not found. Using rgb replacement 
values.
09.01.2009 10:18:48 org.apache.fop.layoutengine.LayoutEngineTestSuite$1 runTest
SCHWERWIEGEND: Error on footnote_changing-page-bpd.xml
09.01.2009 10:18:48 org.apache.fop.layoutengine.LayoutEngineTestSuite$1 runTest

...

------------- ---------------- ---------------
Testcase: 
block-container_absolute-position_multi-column.xml(org.apache.fop.layoutengine.LayoutEngineTestSuite$1):
      Caused an ERROR
Expected XPath expression to evaluate to '1', but got '2' (XPath: 
count(//pageViewport))
java.lang.RuntimeException: Expected XPath expression to evaluate to '1', but 
got '2' (XPath: count(//pageViewport))
        at org.apache.fop.layoutengine.EvalCheck.check(EvalCheck.java:83)
        at 
org.apache.fop.layoutengine.LayoutEngineTester.checkAll(LayoutEngineTester.java:235)
        at 
org.apache.fop.layoutengine.LayoutEngineTester.runTest(LayoutEngineTester.java:182)
        at 
org.apache.fop.layoutengine.LayoutEngineTestSuite$LayoutEngineTestCase.testMain(LayoutEngineTestSuite.java:219)
        at 
org.apache.fop.layoutengine.LayoutEngineTestSuite$1.runTest(LayoutEngineTestSuite.java:193)


Testcase: 
block-container_reference-orientation_bug36391.xml(org.apache.fop.layoutengine.LayoutEngineTestSuite$1):
      Caused an ERROR
Expected XPath expression to evaluate to '[0.0 -1.0 1.0 0.0 0.0 31000.0]', but 
got '[-1.0 -0.0 0.0 -1.0 30000.0 15400.0]' (XPath: 
//mainReference/span/flow[1]/block[4]/block[1]/block[1]/@ctm)
java.lang.RuntimeException: Expected XPath expression to evaluate to '[0.0 -1.0 
1.0 0.0 0.0 31000.0]', but got '[-1.0 -0.0 0.0 -1.0 30000.0 15400.0]' (XPath: 
//mainReference/span/flow[1]/block[4]/block[1]/block[1]/@ctm)
        at org.apache.fop.layoutengine.EvalCheck.check(EvalCheck.java:83)
        at 
org.apache.fop.layoutengine.LayoutEngineTester.checkAll(LayoutEngineTester.java:235)
        at 
org.apache.fop.layoutengine.LayoutEngineTester.runTest(LayoutEngineTester.java:182)
        at 
org.apache.fop.layoutengine.LayoutEngineTestSuite$LayoutEngineTestCase.testMain(LayoutEngineTestSuite.java:219)
        at 
org.apache.fop.layoutengine.LayoutEngineTestSuite$1.runTest(LayoutEngineTestSuite.java:193)

...

Test org.apache.fop.layoutengine.LayoutEngineTestSuite FAILED

Am I doing something wrong here or are these testcases not supposed to succeed?
Regards,
Georg Datterl

Reply via email to