[ 
https://issues.apache.org/jira/browse/FOP-2218?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13592225#comment-13592225
 ] 

Francesco Chicchiriccò commented on FOP-2218:
---------------------------------------------

Agree that building and running are different actions: only, when you set 
"javac.target" to 1.5, the produced bytecode will work only on JDK >= 1.5; as 
reported in [1] for -target, in fact, "Generate class files that target a 
specified version of the VM. Class files will run on the specified target and 
on later versions, but not on earlier versions of the VM."

Anyway, the specific problem reported in [2] was reported when running Apache 
Cocoon 2.1.12-dev with FOP 1.1 on JDK 1.4.2:

bad class file: 
..../cocoon_2_1/lib/optional/fop-1.1.jar(org/apache/fop/apps/FOPException.class)
class file has wrong version 49.0, should be 48.0

[1] http://docs.oracle.com/javase/6/docs/technotes/tools/windows/javac.html
[2] http://markmail.org/message/ga5u5oxhhuqtsupx
                
> 1.1 is reported working with JRE >= 1.4
> ---------------------------------------
>
>                 Key: FOP-2218
>                 URL: https://issues.apache.org/jira/browse/FOP-2218
>             Project: Fop
>          Issue Type: Bug
>          Components: documentation
>    Affects Versions: 1.1
>            Reporter: Francesco Chicchiriccò
>
> In [1] it is stated that "Java 1.4.x or later Runtime Environment." is 
> required for running FOP 1.1.
> However, as reported in [2], 1.5 is required.
> [1] http://xmlgraphics.apache.org/fop/1.1/running.html
> [2] http://svn.apache.org/repos/asf/xmlgraphics/fop/tags/fop-1_1/build.xml

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to