Hi Andreas, 

On 2015-06-01 Andreas Delmelle wrote:
> >
> > before reporting one issue I tried to test the trunk first, but any
> > conversion fails with the error below. I built FOP from sources 
> > using 'ant package' and executing commands (Windows)
> > fop input.fo output.pdf
> >
> > Is this something to do with my build or FOP itself?
> I have seen that before, and if I interpret correctly, the issue is the
> result of having an older FOP version in the classpath at runtime...
> Seems like a newer version of the o.a.f.fo.Constants interface is used
> with an older version of o.a.f.fo.PropertyList, or something like that.
> Try to make sure the JAR you built from trunk is the only version
> accessible to the class loader, and it should be OK.

I had some stuff in the build folder from some old attempts so I deleted it
now completely. After building it works fine! 

I am a bit confused as I also tried 'ant all' before which I expected should
clean this.

Thanks for the hint.


Reply via email to