ok, I run the same thing with PDFRenderer, and I found no problems there.
This means that the multithreading issue is either within

a) AWTRenderer
b) TIFFRenderer (subclass of AWTRenderer)
c) pja X-Server emulation.

Since the issue is, that fontsize-changes from one Renderer influence
another Renderer, I suspect the mistake to be in a) or c). AFAIK FOP paints
the characters to the InMemory-Image in these classes. Is this correct?

Has anyone used AWTRenderer in a mutlithreaded environment? Are there any
known limitations?

thanks,
Reto





Oleg Tkachenko <[EMAIL PROTECTED]> on 31.01.2003 16:05:31

            Bitte antworten an [EMAIL PROTECTED]

An:      [EMAIL PROTECTED]
Kopie:

Thema:   Re: multithreading issues - FOP, TIFFRenderer, Solaris 4-proc
         machine, pja x-server

[EMAIL PROTECTED] wrote:

> I am using FOP 0.20.5rc to produce TIFF files from XML in an EJB
> environment. I experience  strange multithreading issues when I run the
> thing in the (production-near) test-environement on a 4-proc box - the
font
> sizes get messed up completly on the 4 proc machine but only if I render
> more than 1 TIFF in parallel.
> If I run only one rendering at a time, it is fine.
> If I run the same thing multithreaded on my dev box, it runs fine (though
> there is only one proc of course)
>
> It is entierly possible that the TIFFRenderer (from Oleg, based on
> AWTRenderer and JAI), or the pja toolkit (http://www.eteks.com/pja/en/)
is
> the problem.

Yes, you have to isolate problem somehow. Can you test it without
TIFFRenderer, using just regular PDFRenderer?

--
Oleg Tkachenko
eXperanto team
Multiconn Technologies, Israel


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]









---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to