Hi, fossil json api users, A forewarning and request for opinions: i plan to make a few incompatible changes in the json api over the weekend and would like to ask that anyone who would be unduly pained by these changes please speak up (and i will delay the change until a comprise can be found)...
1) timestamps are currently Unix epoch seconds, partly for portability and partly because i did not know at the time that fossil supported better precision. I "would like to" convert to unix epoch + milliseconds (though i am going to go have to fix a boatload of code and docs when i do), and this change is high on my list. 2) some instances of the "uuid" property will be renamed to "checkin" to avoid semantic confusion between checkin uuids vs what i call blob uuids. With the current naming it is not always apparent which form of uuid is provided. The distinction is significant because many commands require either a checkin _or_ non-checkin uuid, but do not handle both. 3) remove the isDir property from the /json/dir output because we already have a good is-dir heuristic : any element without a uuid is a directory. Happy hacking!
_______________________________________________ fossil-users mailing list [email protected] http://lists.fossil-scm.org:8080/cgi-bin/mailman/listinfo/fossil-users

