On Tue, Jan 21, 2014 at 1:28 PM, Stephan Beal <[email protected]> wrote:
> On Tue, Jan 21, 2014 at 7:26 PM, Richard Hipp <[email protected]> wrote: > >> On Tue, Jan 21, 2014 at 1:18 PM, Stephan Beal <[email protected]>wrote: >> >>> >>> Feedback .... welcomed,... >>> >> >> Maybe use strglob() instead of fossil_strncmp() and change the name of >> the parameter from dir= to glob=? Then you do things like ....&glob=*.h to >> get just the diffs in header files, for example. >> > > +1. i'll give it a go. If would, please: take a look at how pFileFrom and > pFileTo are being advanced. i don't think my logic there is 100% correct. > > Your right in that the manifest_file_next() logic is wrong. My first thought on how to fix it would be to send the zDir parameter into append_file_change_line() and let it decide whether or not to show the diff. But then I went looking and saw that the logic is already there!!!! There is an undocumented parameter to /vdiff that lets you specify a regular expression of which files to display. So the functionality that Machai wants is already in trunk. Just add "&re=prefix/.*" to the query. No need for the "&dir=" parameter. -- D. Richard Hipp [email protected]
_______________________________________________ fossil-users mailing list [email protected] http://lists.fossil-scm.org:8080/cgi-bin/mailman/listinfo/fossil-users

