Hi Fred, hi framers,

I've solved the issue by removing the character tags to format Level1IX  
entries. Now the book will be also easier to maintain.

Thanks for your help and suggestions

Dona


On Jun 15, 2007, at 5:34 PM, Dona Mommsen wrote:

> Hi Fred,
>
> thanks for the quick response on a Friday afternoon.
>
> On Jun 15, 2007, at 4:47 PM, Fred Ridder wrote:
>
>> What you're adding to the index entry is not a paragraph tag;
>> it is a *character* tag.
>
> Sure, my mistake. It is a character tag.
>>
>> If this formatting is something you want to apply to every
>> 1st-level index entry, the way you should do this is by setting
>> the formatting in the paragraph format of the Level1IX paragraph
>> tag in the paragraph catalog of the IX file. Doing global formatting
>> in the index entries themselves is simply a mainetnance nightmare.
>
> Hindsight is such a wonderful thing. You are absolutely right. The  
> problem was that I botched up the index structure in the first place.  
> I had no experience, so I created a real mess concerning the selection  
> and structure of terms. So when I redid the index, the manual  
> character tags helped me to single out the index entries were already  
> revised. Now with the revised structure, it might be worthwhile to  
> remove all the manual tags again.
>
>
>>
>> As to why your index entries aren't working properly, I'm not
>> sure I have any good ideas. One thing you might want to try
>> (assuming that you really do intend to stick with the approach
>> of applying character formatting in the index entries) is to
>> explictly cancel the character format at the ned of the top-
>> level entry using <Default Para Font> just before the first
>> colon.
>
> Unfortunately that didn't help.
>>
>> And just to make sure: You're not including paragraph breaks
>> or line breaks in your index markers, are you? There's a known
>> bug in FrameMaker relating to that.
>
> I didn't know about that known bug, but I double checked that I have  
> neither a paragraph break nor a line break in the index entry.
>
> Moreover, my problem does not seem to have anything to do with my  
> character tag.
> I created a new document from the standard template (blank portrait),  
> and added just a few 2nd and 3rd level index entries. I touched the  
> file as little as possible: No copy/ paste from my document that could  
> include any corrupt stuff. No formatting, no changes on the reference  
> pages. Then I created a new book, and added a standard index. I did no  
> tweaking whatsoever, and I get the same behavior.
>
> Any further suggestions are appreciated.
>
> Dona
>
>>
>>
>>
>>> From: Dona Mommsen <dona.mommsen at gmx.net>
>>> To: framers at lists.frameusers.com
>>> Subject: 3rd level index entry problem
>>> Date: Fri, 15 Jun 2007 16:15:07 -0500
>>>
>>> Dear Framers,
>>>
>>> I'm using Frame 7.0 on Mac 10.3.9, and I'm having trouble with 3rd  
>>> level index entries for a book.
>>> I'm adding manually a paragraph tag <IndexFirst> to first level  
>>> index entries. Maybe that was a stupid thing to do in the first  
>>> place, and maybe it has nothing to do with my problem. Anyhow, the  
>>> results are fine for first and second level entries. Yet any third  
>>> level entry does not appear at the correct place, reproducing all 3  
>>> levels in its own entry.
>>>
>>> Example:
>>>
>>> This creates a correct second level entry:
>>> <IndexFirst>customer:corporate customer
>>>
>>> This creates an incorrect third level entry
>>> <IndexFirst>customer:corporate customer:scenarios
>>>
>>> Snippet from the resulting Index:
>>>
>>> customer
>>>     corporate customer
>>>             scenarios 306?308
>>> customer
>>>     <<other 2nd level entries here>>
>>>     corporate customer 19, 50, 63, 147, 149
>>>             <<scenarios does NOT show up as 3rd level entry here>>
>>>
>>> AFAIK it has noting to do with the page ranges, since I get the same  
>>> behavior with other entries that are for a single page. In fact, I  
>>> get the same behavior for any 3rd level entries that I've tried so  
>>> far. I also tried to force the entry by adding a sort order  
>>> [customer:corporate customer], which seems to be ignored. What am I  
>>> missing?
>>>
>>> Thanks in advance for any help
>>>
>>> Dona
>>
>> _________________________________________________________________
>> PC Magazine?s 2007 editors? choice for best Web mail?award-winning  
>> Windows Live Hotmail.  
>> http://imagine-windowslive.com/hotmail/?locale=en- 
>> us&ocid=TXT_TAGHM_migration_HM_mini_pcmag_0507
>>
>
> _______________________________________________
>
>
> You are currently subscribed to Framers as dona.mommsen at gmx.net.
>
> Send list messages to framers at lists.frameusers.com.
>
> To unsubscribe send a blank email to
> framers-unsubscribe at lists.frameusers.com
> or visit  
> http://lists.frameusers.com/mailman/options/framers/ 
> dona.mommsen%40gmx.net
>
> Send administrative questions to listadmin at frameusers.com. Visit
> http://www.frameusers.com/ for more resources and info.
>


Reply via email to