Hi,

I guess this is a Distiller rather than FrameMaker problem and I seem to
have a workaround, but I would be interested to know if anyone on this list
knows about the problem and has a more direct solution.

When generating PDF for a book from FrameMaker, the process stops in the
last pages with the message

--------
%%[ ProductName: Distiller ]%%
%%[Page: 1]%%
%%[Page: 2]%%
%%[Page: 3]%%
%%[Page: 4]%%
%%[ Error: typecheck; OffendingCommand: pdfmark; ErrorInfo: StOBJ
--nostringval-- ]%%

Stack:
/StOBJ
{A.4.299011.1}
/Obj
-dict-


%%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
%%[ Warning: PostScript error. No PDF file produced. ] %%
----------

Version: FrameMaker on Windows, 7.2b128. 

Before my latest changes to the book, FrameMaker was generating PDF fine.

I was rather devastated this when I suddenly hit this. Then, since I
fortunately have Distiller (version 9.0.11), I generated Postscript for the
book; this worked, then I distilled the result separately, which also
worked. I hope this somewhat tedious workaround continues to work; I assume
FrameMaker uses another version of Distiller (and I did not see a way to
tell FrameMaker to use another). Still, if anyone has a better suggestion I
would be most grateful.

Thanks, 

-- Bertrand Meyer
ETH Zurich

Reply via email to