on Monday 02 July 2012 at 19:28, matt wrote:
> It's possible you have a crashed EC or need a bios update, a lot of that 
> stuff seems wrong.

I tried with the battery inserted, in case that messed up something, but
the only differences are hw.acpi.battery.state (2 instead of 7), and
temperature and fan speed readings.

> If the EC is crashed, the fix used to be removing battery, holding power 
> button for 10 seconds and reinstalling battery...I usually see this 
> stuff on Macbooks, but, I suppose it's possible the EC is in an 
> "unplanned" state and thus has corrupted some values...many of the ACPI 
> calls query the EC.

I tried that (well 15s actually), and I haven't seen any difference.

Is there a more definite way to test whether it is the case?

> It's also possible you are running an old bios? Trying to get a few 
> things to work, I had the latest bios on my x220...never had problems 
> with the power button.

So the UEFI BIOS claims to have version 8DET58WW (1.28), dated as
2012-02-14, while EC versions claims to be 8DHT29WW (1.13).

According to leveno website, that's two releases behind. I will try to
update it, despite my uneasiness caused by previous bad experiences.
Still I'm not exactly sure how to perform it, since I inadvertently
destroyed the Windows pre-installation, and I have no optical drive.

Though I will probably try with CURRENT instead of STABLE before trying
BIOS update, since it's much easier to perform and I only need time to
get at it.

Thanks for your help,
Natacha Porté
freebsd-acpi@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-acpi-unsubscr...@freebsd.org"

Reply via email to