Hello,

on Saturday 30 June 2012 at 09:21, Erich Dollansky wrote:
> sorry for the late reply. As usual, I have had to travel and did not
> get a chance to connect to the Internet.

No problem, I'm at least as slow with e-mail, and I don't even have any
excuse ;-)

> On Thursday, June 28, 2012 05:08:57 PM Natacha Porté wrote:
> > I'm using a 9-STABLE with only "LEN0086" addition and Intel_GPU patches
> > form CURRENT. Could it be caused by new developments in CURRENT? Or have
> > you modified or configured something?
> > 
> let me tell you my experience. I have had a horrible experience with
> 9. I mean, horrible compared to what I normally experience with
> FreeBSD. I simply did not get it working at all. As I needed the
> machine, I installed Fedora 16. At least it worked. I was most happy
> when I could install FreeBSD 10 and it worked after I did not need
> that machine that urgent for work anymore.

OK, I will try it with CURRENT as soon as I get the opportunity (I
already have a thumb drive dedicated for that kind of tests).

> > For the reference, in case it might help, here are some relevant sysctl:
> > $ sysctl hw.acpi
> 
> Let me compare;
> 
> > hw.acpi.battery.life: -1
> 
> How did you get this value? No battery inserted? The range should be
> from 0 to 100.

Indeed, I had no battery inserted. Years ago I took the habit of
removing the battery of laptops used for long amount of time on AC
(currently for my X220, that's 9h every workday), because keeping a
fully charged battery on AC used to kill it. However I admit I don't
know whether technology improved enough to mnake it a non-issue (or even
whether even by then it was actually an issue and not an urban legend).

Anyway, now with the battery inserted and charging, I still have
hw.acpi.battery.life: -1.
However, as soon as I unplug, I get a reasonable value there (currently
98, with hw.acpi.battery.time: 265).

> > hw.acpi.battery.time: -1
> > hw.acpi.battery.state: 7
> 
> I have 0 here.

I have 2 when it's charging, and 1 when it's discharging.

> > $ sysctl dev.acpi_ibm
> 
> I do not have anything with IBM or Lenovo.
> 
> I also did not load anything specific for the X220 except of the Intel KMS 
> module.

Interesting, though it turns out that not using it on my 9-STABLE does
not help with any of the small issues I still have. Though I will try
both with and without it when I experiment with CURRENT. Thanks for the
point.


Thanks for your help,
Natacha Porté
_______________________________________________
freebsd-acpi@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-acpi
To unsubscribe, send any mail to "freebsd-acpi-unsubscr...@freebsd.org"

Reply via email to