Thank you quickly solve this problem. 
Last night successfully compiled kernel, but the problem is still not resolved 
after recovery sleep, the phenomenon persists, restore the notebook when there 
is energized action, but the hard drive lights under no response, the screen 
does not display, only the shutdown restart.


发件人: Anthony Jenkins [mailto:anthony.b.jenk...@att.net] 
发送时间: 2014年8月26日 23:20
收件人: 张晓靖
主题: Re: 答复: 答复: 答复: 答复: My laptop can't resume from suspend.

Run the patch through 'dos2unix' (/usr/ports/textproc/unix2dos package):
[root@ajenkins-hplaptop /usr/src]# file atrtc.c.patch 
atrtc.c.patch: unified diff output, ASCII text, with CRLF line terminators
[root@ajenkins-hplaptop /usr/src]# dos2unix atrtc.c.patch 
[root@ajenkins-hplaptop /usr/src]# file atrtc.c.patch 
atrtc.c.patch: unified diff output, ASCII text
(I had to fake a DOS-ified patch file for this example by running it through 
unix2dos first), but Hotmail likely converted it to DOS line endings.

Anthony

On 08/26/2014 10:54, 张晓靖 wrote:
Also learned, thanks.
patch when there are mistakes. Attachment is generated atrtc.c.rej

root@skycn:/usr/src # patch -p0 < /root/atrtc.c.patch
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sys/x86/isa/atrtc.c
|===================================================================
|--- sys/x86/isa/atrtc.c        (revision 268728)
|+++ sys/x86/isa/atrtc.c        (working copy)
--------------------------
Patching file sys/x86/isa/atrtc.c using Plan A...
Hunk #1 failed at 31.
Hunk #2 failed at 54.
Hunk #3 failed at 74.
Hunk #4 failed at 163.
Hunk #5 failed at 179.
Hunk #6 failed at 306.
Hunk #7 failed at 354.
Hunk #8 failed at 443.
8 out of 8 hunks failed--saving rejects to sys/x86/isa/atrtc.c.rej
Done


发件人: Anthony Jenkins [mailto:anthony.b.jenk...@att.net] 
发送时间: 2014年8月26日 20:23
收件人: 张晓靖
主题: Re: 答复: 答复: 答复: My laptop can't resume from suspend.

1. Install FreeBSD source tree.
2. Download patch file.
3. 'cd' to /usr/src.
4. Execute 'patch -p0 < path/to/atrtc.c.patch'
5. Rebuild and install kernel ('make kernel 
KERNCONF=YOUR_KERNEL_CONFIG_FILE_NAME && reboot')
6. Test suspend/resume.
Anthony
References:
• 
https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/kernelconfig-building.html

On 08/26/2014 05:33, 张晓靖 wrote:
Thanks so quick reply, for the use of patch files I have no experience, from 
the freebsd manual and the Internet did not find a reliable upgrade process, 
you can tell me how to use this patch file to upgrade atrtc.c it? For the use 
of the code, I was a rookie, needs your help. 

Or tell me which part of the contents of the manual freebsd can guide me to 
upgrade atrtc.c code, thank you.

-----邮件原件-----
发件人: Anthony Jenkins [mailto:anthony.b.jenk...@att.net] 
发送时间: 2014年8月26日 0:11
收件人: 张晓靖
抄送: freebsd-acpi@freebsd.org
主题: Re: 答复: 答复: My laptop can't resume from suspend.

No problem... attached.  And amd64 doesn't matter - works for x86-based 
computers with the basic CMOS RTC chip (PNP0B00).  Hopefully your 
suspend/resume problems are due to your ACPI BIOS needing to read/write info 
from/to CMOS and not finding a CMOS handler.

Anthony

On 08/25/2014 11:50, 张晓靖 wrote:
I google less than complete information. Do you have the relevant code can be 
shared under it? I found atrtc.c file in /usr/src/sys/x86/isa directory, but my 
system is amd64 of ...... 

root@skycn:~ # uname -a
FreeBSD skycn 10.0-RELEASE-p7 FreeBSD 10.0-RELEASE-p7 #2: Sat Aug 16 00:06:30 
CST 2014     root@skycn:/usr/obj/usr/src/sys/MyKernel  amd64


-----邮件原件-----
发件人: Anthony Jenkins [mailto:anthony.b.jenk...@att.net]
发送时间: 2014年8月16日 5:18
收件人: 张晓靖; 'Kevin Oberman'
抄送: freebsd-acpi@freebsd.org
主题: Re: 答复: My laptop can't resume from suspend.

On 08/15/2014 16:20, 张晓靖 wrote:
Thank Bykov Vladislav and Kevin Oberman's recommendations. Later I 
received an e-mail,

immediately compile the kernel (make a note #options VESA).But the 
problem persists, dmesg

Information Reference url http://url.cn/SQ0vXD. 

 

Even worse thing is, I do use "acpiconf -s 3"debugger, resulting in a 
notebook can not boot

until yesterday afternoon for a good notebook motherboard, now do not 
dare to use “acpiconf

-s 3” testing. 

 

Do you have suggestions for me?
You could dig up my kernel patch (Google "FreeBSD ACPI CMOS region support 
atrtc.c.patch") to play with, it works to enable suspend/resume on some laptops 
and should be safe to try.  I still need to clean it up (style, other 
suggestions) for submission to FreeBSD, haven't gotten around to it yet.

Anthony Jenkins

Thanks you~

 

 

 

-----邮件原件-----
发件人: Bykov Vladislav [mailto:envol...@gmail.com]
发送时间: 2014年8月13日 0:13
收件人: 张晓靖
主题: Re: My laptop can't resume from suspend.

 

On Tue, Aug 12, 2014 at 12:20:28PM +0800, 张晓靖 wrote:

The laptop can't resume, the screen no display, no beep sound. 
Can you please try to install video driver for your card and remove VESA device 
from kernel configuration?

 

 

发件人: kob6...@gmail.com [mailto:kob6...@gmail.com] 代表 Kevin Oberman
发送时间: 2014年8月13日 1:15
收件人: 张晓靖
抄送: freebsd-acpi@freebsd.org
主题: Re: My laptop can't resume from suspend.

 

On Mon, Aug 11, 2014 at 9:20 PM, 张晓靖 <zhangxiaoj...@hotmail.com 
<mailto:zhangxiaoj...@hotmail.com> > wrote:

Hello,

       I am having a problem.

       My laptop is lenovo's zhaoyang K47A series HM65.

       I used ati graphics CARDS, Use the url ( 
<https://wiki.freebsd.org/Graphics> 
https://wiki.freebsd.org/Graphics)
the method of normal driving the graphics card.



      After set "

sysctl debug. Bootverbose = 1

sysctl debug. Acpi. Suspend_bounce = 1

sysctl debug. Acpi. Resume_beep = 1

acpiconf -s 3

"

The laptop can't resume, the screen no display, no beep sound.



Disabling ACPI not helps to fix the problem. All files downloaded 
from http://url.cn/WVISGF.



Output from sysctl hw.acpi

hw.acpi.supported_sleep_state: S1 S3 S4 S5

hw.acpi.power_button_state: S5

hw.acpi.sleep_button_state: S1

hw.acpi.lid_switch_state: NONE

hw.acpi.standby_state: S1

hw.acpi.suspend_state: S3

hw.acpi.sleep_delay: 1

hw.acpi.s4bios: 0

hw.acpi.verbose: 1

hw.acpi.disable_on_reboot: 0

hw.acpi.handle_reboot: 0

hw.acpi.reset_video: 0

hw.acpi.cpu.cx_lowest: C1

hw.acpi.acline: 1

hw.acpi.battery.life: 100

hw.acpi.battery.time: -1

hw.acpi.battery.state: 0

hw.acpi.battery.units: 2

hw.acpi.battery.info_expire: 5

hw.acpi.thermal.min_runtime: 0

hw.acpi.thermal.polling_rate: 10

hw.acpi.thermal.user_override: 0

hw.acpi.thermal.tz0.temperature: 62.0C

hw.acpi.thermal.tz0.active: -1

hw.acpi.thermal.tz0.passive_cooling: 1

hw.acpi.thermal.tz0.thermal_flags: 0

hw.acpi.thermal.tz0._PSV: 95.0C

hw.acpi.thermal.tz0._HOT: -1

hw.acpi.thermal.tz0._CRT: 100.0C

hw.acpi.thermal.tz0._ACx: -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

hw.acpi.thermal.tz0._TC1: 2

hw.acpi.thermal.tz0._TC2: 3

hw.acpi.thermal.tz0._TSP: 100



Sincerely,
ZhangXiaoJing.

 

Have you tried building the kernel without VESA? Many laptops won't resume if 
you leave VESA in the kernel build. 

--


R. Kevin Oberman, Network Engineer, Retired
E-mail: rkober...@gmail.com <mailto:rkober...@gmail.com>

_______________________________________________
freebsd-acpi@freebsd.org mailing list 
http://lists.freebsd.org/mailman/listinfo/freebsd-acpi
To unsubscribe, send any mail to "freebsd-acpi-unsubscr...@freebsd.org"








_______________________________________________
freebsd-acpi@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-acpi
To unsubscribe, send any mail to "freebsd-acpi-unsubscr...@freebsd.org"

Reply via email to