On Thu, 21 Apr 2016 23:03:05 +0200, Michael Freisinger wrote:
 > Hello,
 > I've built up a NAS system with the following hardware:
 > - Mainboard: ASUS B150M-K D3 LGA1151
 > - CPU: Intel BX80662G4400 Prozessor
 > - RAM: 2x 8GB Kingston ValueRAM DDR3-1600 DIMM CL11 Single
 > As OS I'm using FreeNAS V9.10 that is based on FreeBSD.

FreeBSD 10.3-RELEASE #0 f935af8(freebsd10): Mon Apr 18 10:58:36 PDT 2016
 build-freenas9/_BE/trueos/sys/FreeNAS.amd64 amd64

Since it's based on 10.3, I'd suggest booting from a 10.3 CD or memstick 
in "Live CD" mode and testing suspend / resume from there, just to rule 
out any possible differences with the FreeNAS configuration?  If this 
problem then persists, people can test against a more familiar baseline.

 > I'm using this OS, because it provides the possibility to encrypt my data.
 > Therefore it is necessary to enter a passphrase to unlock my hard drives
 > after each reboot.
 > Since I don't want to run the NAS all time and I don't want to enter the
 > passphrase for each access, the suspend to RAM mode is very important for
 > me.
 > And here is my problem:
 > When I execute the command "acpiconf -s 3" the system is starting to
 > suspend. However after a while (just a few seconds) the system is rebooting
 > (ASUS boot screen is displayed) and I have to type in the passphrase again.
 > I already tried to fix this with your description from chaptor "
 > System Powers Up After Suspend or Shutdown", but without success.

It's section in the current online Handbook.

Have you tried it without (from your sysctl hw.acpi)
hw.acpi.handle_reboot: 1 ?

Have you tried with the advice from (online) section, namely:
 # sysctl debug.bootverbose=1
 # sysctl debug.acpi.suspend_bounce=1
 # acpiconf -s 3

 > I attached some logs. I thing the names are self-explanatory.
 > The  ACPI Source Language file can be found here:
 > https://dl.dropboxusercontent.com/u/17336975/root-ASUSB150M-KD3LGA1151.asl
 > If you need further logs or information, please contact me.

If nothing more informative turns up soon, you might want to add or 
point to a dmesg from booting in verbose mode.  From what's there now, I 
don't know whether these may be significant?

ACPI Error: [\134_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, 
AE_NOT_FOUND (20150515/dswload-219)
ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20150515/psobject-233)

cheers, Ian
freebsd-acpi@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-acpi-unsubscr...@freebsd.org"

Reply via email to