On 2013-11-26 15:07, Beeblebrox wrote:
> I had a previously discussed zpool related error on my susytem:
> (http://freebsd.1045724.n5.nabble.com/zpool-requires-re-import-on-reboot-td5861930.html#a5862468).
> This may be related.
> Now a different but equally odd error: On one of the pools with the import
> problem (poolname=da), I had:
> zfs set sharenfs="-network=" da/data/amd64
> When I start nfsd + mountd, TTY0 shows this error:
> bad exports list line: /mnt/data/amd64
> bad exports list line: /mnt/amd64
> I can only assume that I had the da zpool mounted as altroot=/mnt at some
> point in its history. After I 
> zfs set sharenfs=off da/data/amd64 
> for debugging, the error persisted for some time then was gone when I first
> tried; now it persists even after a pool scrub. ZDB shows nothing odd with
> the "-Cl /dev/ada1p2" flag, but,
> zdb -d da/data/amd64
> zdb: can't open 'da/data/amd64': No such file or directory
> I have same error for all pool-type commands. "# zdb -C da" for example.
> Regards
> -----
> FreeBSD-11-current_amd64_root-on-zfs_RadeonKMS
> --
> View this message in context: 
> http://freebsd.1045724.n5.nabble.com/ZFS-sharenfs-and-zdb-no-such-file-errors-tp5864187.html
> Sent from the freebsd-current mailing list archive at Nabble.com.
> _______________________________________________
> freebsd-current@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-current
> To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"
NFS related config for ZFS is stored in /etc/zfs/exports
and mountd just reads that in addition to the usual /etc/exports

you might want to check there

Allan Jude

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to