I've nevery used this but Error 13 is permission denied in errno.h
so I've guessing something has messed with some permissions possibly
a file permission there somewhere?

If its not obvious, the you could try run it under truss to see what
is returning error 13.

----- Original Message ----- From: "O. Hartmann" <ohart...@zedat.fu-berlin.de>

After updating ports yesterday with all this ICU update horror today
slapd rejects to start out of the blue after months of working like a

5399feba slapd startup: initiated.
5399feba backend_startup_one: starting "cn=config"
5399feba config_back_db_open
5399feba send_ldap_result: conn=-1 op=0 p=0
5399feba backend_startup_one: starting "dc=dumami"
5399feba mdb_db_open: database "dc=dumami":
dbenv_open(/var/db/openldap-data/). 5399feba mdb_db_open: database
"dc=dumami" cannot be opened, err 13. Restore from
backup! 5399feba backend_startup_one (type=mdb,
suffix="dc=dumami"): bi_db_open failed! (13) 5399feba
slapd shutdown: initiated 5399feba slapd destroy: freeing system
resources. 5399feba syncinfo_free: rid=001 5399feba syncinfo_free:
rid=003 5399feba slapd stopped.
/usr/local/etc/rc.d/slapd: WARNING: failed to start slapd

According to that useless "suggestion" to restore from backup, I
restored the configuration and the users from backups. slapadd works
fine. But then starting the server fails again.

Via "portmaster -f openldap24-server" I tried to rebuild all ports
necessary for that fragile OpenLDAP thing, but still no success. I can
not find any hints in the log (using -d1 or -d257 starting slapd)
except the failure shown above. Since the very same configuration and
dataset worked for months now and even after the massive icu-related
update of ports yesterday (ended by restarting slapd), I wouldn't
expect any usefull hint.

Can anybody offer suggestions, please? I'm out of ideas. I find it very


freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to