On Fri, 15 Jan 2016 13:35:01 -0500
Michael Butler <i...@protected-networks.net> wrote:

> On 01/15/16 13:24, David Wolfskill wrote:
> > On Fri, Jan 15, 2016 at 07:19:43PM +0100, O. Hartmann wrote:  
> >> On FreeBSD 11.0-CURRENT #1 r294070: Fri Jan 15 06:21:20 CET 2016 amd64,
> >> loading nvidia kernel module results in the error:
> >>
> >> KLD nvidia-modeset.ko: depends on kernel - not available or version
> >> mismatch linker_load_file: Unsupported file type
> >>
> >> This worked prior to r294070
> >> ....  
> > 
> > My most recent build of head was at r294086; I didn't see a problem with
> > nvidia -- but I have 'PORTS_MODULES=x11/nvidia-driver' in /etc/src.conf,
> > so it's rebuilt every time I rebuild the kernel.
> > 
> > Have you rebuilt nvidia-driver recently?  
> 
> This is as a consequence of the following change. You need to rebuild
> all modules to match the kernel:
> 
> ------------------------------------------------------------------------
> r294086 | hselasky | 2016-01-15 06:18:58 -0500 (Fri, 15 Jan 2016) | 7 lines
> Changed paths:
>    M /head/sys/compat/linuxkpi/common/include/linux/pci.h
>    M /head/sys/compat/linuxkpi/common/src/linux_pci.c
>    M /head/sys/sys/param.h
> 
> Implement support for PCI suspend, resume and shutdown events in the
> LinuxKPI. Fix a few spaces to tabs. Bump the FreeBSD version to force
> recompilation of existing KMODs.
> 

Or build it without Linux support.

Mine was built on October 17, 2015 and I'm running r294095 without
a problem.

-- 
Gary Jennejohn
_______________________________________________
freebsd-current@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to