If you implement a new IO scheduler you can name it whatever you like.
"NG" isn't any more meaningful than "Netflix."


On Fri, Apr 15, 2016 at 9:13 AM, Maxim Sobolev <> wrote:
> Great, work Warner, thanks! Small note, though. The CAM_IOSCHED_NETFLIX
> seems like a quite poor name for a kernel option. IMHO there is no good
> reason for polluting it with the name of the company that sponsored the
> development. I don't think we have any precedents of doing this unless the
> option is related to a piece of hardware that the company makes, and it's
> not the case here. Apart from "coolness" factor as far as I understand that
> _NETFLIX suffix does not give any tangible benefit for anybody reading
> kernel config and trying to understand what this option actually does.
> CAM_IOSCHED_SSDNG or something would be better IMHO. Just my $0.02.
> -Max
> On Thu, Apr 14, 2016 at 3:42 PM, Warner Losh <> wrote:
>> The CAM I/O scheduler has been committed to current. This work is described
>> in though the
>> default scheduler doesn't change the default (old) behavior.
>> One possible issue, however, is that it also enables NCQ Trims on ada SSDs.
>> There are a few rogue drives that claim support for this feature, but
>> actually implement data corrupt instead of queued trims. The list of known
>> rogues is believed to be complete, but some caution is in order.
>> Warner
>> _______________________________________________
>> mailing list
>> To unsubscribe, send any mail to ""
> _______________________________________________
> mailing list
> To unsubscribe, send any mail to ""
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to