I just upgraded my home machine from 4.0-R to 5.0-CURRENT and have found
something odd. I have an ISA PnP SB AWE64 in the machine and it is not seen by
the system at all.

I found this in dmesg:

isab0: <Intel 82371SB PCI to ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
isa0: unexpected small tag 14
unknown: <Audio> can't assign resources

Any idea why ? The 'small tag' error worries me...

Messages from older boot:

sbc0: <Creative SB AWE64> at port 0x220-0x22f,0x330-0x331,0x388-0x38b irq 5 drq 1,5 on 
sbc0: setting card to irq 5, drq 1, 5
pcm0: <SB DSP 4.16> on sbc0

pnpconfig still sees the card:

Checking for Plug-n-Play devices...

Card assigned CSN #1
Vendor ID CTL00e4 (0xe4008c0e), Serial Number 0x128bf1e3
PnP Version 1.0, Vendor Version 16
Device Description: Creative SB AWE64  PnP
*** Small Vendor Tag Detected

Logical Device ID: CTL0045 0x45008c0e #0
Device Description: Audio
TAG Start DF
Good Configuration
    IRQ: 5  - only one type (true/edge)
    DMA: channel(s) 1 
        8-bit, not a bus master, count by byte, , Compatibility mode
    DMA: channel(s) 5 
        16-bit, not a bus master, , count by word, Compatibility mode
    I/O Range 0x220 .. 0x220, alignment 0x1, len 0x10
        [16-bit addr]
    I/O Range 0x330 .. 0x330, alignment 0x1, len 0x2
        [16-bit addr]
    I/O Range 0x388 .. 0x388, alignment 0x1, len 0x4
        [16-bit addr]
TAG Start DF

Ollivier ROBERT -=- FreeBSD: The Power to Serve! -=- [EMAIL PROTECTED]
FreeBSD keltia.freenix.fr 4.0-CURRENT #78: Sun Feb 27 15:32:39 CET 2000

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to