I ran into a very nasty situation where I need to save/restore/reinstall a
in-installworld-crashed recent current.

While the /usr/obj and /usr/src as well as /etc folders are intact (residing on
a Samsung 850 pro SSD with UFS and journaling), /boot/kernel vanished and
most binaries in /bin and /sbin are of Null size.

I treid to rescue the system by intending to use the most recent CURRENT ISO
image found on the snapshot server for USB drives, booted this successfully and
then mounted the failes filesystems into the proper place (/usr/obj
and /usr/src onto USB devices /usr/obj and /usr/src respectively, the rest goes
into /mnt).

I tried then to perform a make installworld with DESTDIR=/mnt set. But I fail:
the minimalistic USB image does not have any CLANG/LLVM stuff required for the

Where the hell did this stuff go? Has it been ripped off due to the 1 GB
ancient flash size? 

Help is needed. I've already posted to CURRENT a message, but I guess I always
hit the wrong subject line. It seems that the key to my saviour is to have a
flash drive with a recent CURRENT containing a cc compiler - otherwise /usr/obj
is useless.

Kind reards,

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to