On Sat, 13 May 2017, Ngie Cooper (yaneurabeya) wrote:

On May 13, 2017, at 11:05, Ngie Cooper (yaneurabeya) <yaneurab...@gmail.com> 

On May 13, 2017, at 11:01, Ngie Cooper (yaneurabeya) <yaneurab...@gmail.com> 

        I???ve been noticing some really weird behavior with terminal input 
after updating my kernel/userland ??? in particular, if I do `arc diff 
???create` (which opens vi/vim), and try to do edits/use ^c, it will terminate 
the running process for `arc diff ???create`. Similarly, I was seeing really 
weird input via vim (when doing `svn ci`) where if I had one of the editing 
modes on, like insert, it would delete several lines at once; I worked around 
this by using ^c to terminate insert mode, but that???s a really bad hack. It 
worked ok with r316745, got worse in r317727, and doesn???t seem to be any 
better in r318250.

I forgot to mention: I???m using SSH to access my machine.

My gut feeling is the sc(4) commits might have tickled or introduced some bugs. 
I???ll try reverting the following commits over the next couple days to see 
whether or not my experience improves: r316827 r316830 r316865 r316878 r316974 
r316977 r317190 r317198 r317199 r317245 r317256 r317264.

I don't think I touched anything related to editing.  Certainly not for fixing
the mouse cursor starting some time before r317827.  Since then I have spent
too much time on mouse cursors and not much else.

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to