On Mon, 10 Jul 2017 21:53:11 +0200, Boris Samorodov <b...@passap.ru> wrote:

10.07.2017 22:21, Toomas Soome пишет:

On 10. juuli 2017, at 21:24, Boris Samorodov <b...@passap.ru> wrote:

10.07.2017 21:05, Allan Jude пишет:
On 2017-07-09 14:40, Boris Samorodov wrote:
08.07.2017 18:56, Boris Samorodov пишет:
Hi All,

I tied to install a new FreeBSD-amd-12 system from official USB
installation memstick.img. Auto-UFS (GPT) installs fine and the system
boots fine. However, ZFS-Auto install succeeds, but is not loaded.
At the very beginning it gives something like "gpt sector XXXX error,
gpt sector 1 error, can't find zroot..."

Is it a known error / should I give more (precise) errors?

I tried two recent images with the same result:

It turned out GPT and zfs are not usable at this machine.
MBR / ZFS works fine.

I'll stick with that.

What type of machine is it?

It's a PC circa 2009 with MB ASUS P5QL/EPU:
CPU: Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz (2799.52-MHz
K8-class CPU)
 Origin="GenuineIntel"  Id=0x1067a  Family=0x6  Model=0x17  Stepping=10



 AMD Features=0x20100800<SYSCALL,NX,LM>
 AMD Features2=0x1<LAHF>
 TSC: P-state invariant, performance statistics
real memory  = 4294967296 (4096 MB)
avail memory = 3324891136 (3170 MB)
Event timer "LAPIC" quality 100
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s)

WBR, bsam

Of course it really can not be that the BIOS has something against combination of GPT+ZFS, but this combination may trigger some sort of bug/misbehavior. I have seen some pretty weird issues and have work in process to have a bit more fool proof approach, but I haven't had time yet to finalize it properly.

Yep, UFS+GPT works fine here.

Just for archieves: errors for ZFS + GPT
gptzfsboot: error 128 lba 3907027040
gptzfsboot: error 128 lba 1
gptzfsboot: no zfs pools located, can't boot

The disk is:
        512             # sectorsize
        2000397852160   # mediasize in bytes (1.8T)
        3907027055      # mediasize in sectors
        0               # stripesize
        0               # stripeoffset
        3876018         # Cylinders according to firmware.
        16              # Heads according to firmware.
        63              # Sectors according to firmware.
        WD-WMAUR0112162 # Disk ident.
        Not_Zoned       # Zone Mode

UEFI is not available at the motherboard.

Namely, what I have found is that in some systems the INT13 ah=08 can result with unexpected results - error from command reported or disk count not reported etc - something not really expected. It also may have to do about what other devices are there. And also if the system has plain BIOS or BIOS emulated on UEFI.

This looks similar to: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=144234 Please add your information if you think it is the same issue. Or try the workaround and see if it helps.

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to