On 09/27/17 09:05, Guido Falsi wrote:
On 09/26/2017 15:41, O. Hartmann wrote:
On Tue, 26 Sep 2017 15:06:23 +0200
Guido Falsi <madpi...@freebsd.org> wrote:

Since I run net/asterisk with automatic module loading (I'm new to asterisk),
this is very likely and might cause the problem somehow.

You can exclude single modules from autoloading via modules.conf.

Not sure, restarting the daemon should free any leaked memory the daemon
has. If a killed process leaves memory locked at the system level there
should be some other cause.

Even with no runnidng asterisk, memory level drops after the last shutdown of
asterisk and keeps that low. Even for weeks! My router never shows that high
memory consumption, even under load.

But while asterisk is running does the memory usage increase unbounded
till filling all available memory or does it stabilize at some point?

Asterisk is relatively memory hungry, especially with all modules
enabled. It also caches and logs various information in RAM, even doing
"nothing" it will cache and log that "nothing" activity. If memory does
stabilize after some point it's not really a leak but it's standard
memory usage. To reduce it you should disable all unused modules.

The question would be: how to use vmstat to give hints for those familiar with
memory subsystems to indicate a real bug?

I tried to find some advices, but maybe my English isn't good enough to make
google help.

I'm not able to give you a correct indication, but if the memory usage
is not increasing indefinitely but is stabilizing I'd say it's not
really a leak.

Did you look at the output from "vmstat -m" and "vmstat -z" ?

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to