On 2/19/18 2:21 PM, Kyle Evans wrote:
> Hello!
> On Mon, Feb 19, 2018 at 8:21 AM, Juan Ramón Molina Menor <lis...@club.fr> 
> wrote:
>> I have done a full build of r329555 to test the new Lua boot loader.
>> Both the new and the old kernels panic after being loaded with:
>> panic: running without device atpic requires a local APIC
>> For reasons unknown, ACPI is off, as shown by David Wolfskill in a previous
>> message:
>> https://lists.freebsd.org/pipermail/freebsd-current/2018-February/068497.html
>> OK show hint.acpi.0.disabled
>> 1
>> Setting ACPI to On resolves the issue.
> As David noted, this should actually Just Work (TM) now. Can you break
> into a loader prompt with just the forth loader and tell me what "show
> hint.acpi.0.rsdp" looks like?

This doesn't appear to "just work out-of-the-box" yet when EFI booting
amd64, as I still get the 'no local APIC' panic (I just tried @r329609).

Under EFI and lua loader, the following is set when breaking to prompt:
Under forth loader, this is not present/set.

In neither case is hint.acpi.0.rsdp present/set as that appears to get
set during the exec of the loaded kernel...

I've worked around the issue by adding hint.acpi.0.disabled="0" to
loader.conf (or patching the amd64 efi loader code to explicitly clear
that hint).

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Reply via email to