I ran into an interesting gotcha with fsck and vinum...

   I have the following line in /etc/fstab:

/dev/vinum/raid5        /pub            ufs     rw              2       2

   and during an upgrade (old current to current), I commented the
line out during the reboot process. After bringing the new system
online, I executed:

/sbin/fsck -y /dev/vinum/raid5

and received the following error:

fsck: exec /usr/sbin/fsck_unused for /dev/vinum/raid5: No such file or directory

   Knowing that I've been able to fsck this volume in the
past I checked for a vinum specific fsck binary. Nothing
there. It then occurred to me it's a ufs volume, and I've
always fsck'd it by mount point. I then uncommented the
line in /etc/fstab and executed: 

/sbin/fsck -y /pub

and it worked correctly.

   After the above (with the /etc/fstab line uncommented), I

/sbin/fsck -y /dev/vinum/raid5    

   and it worked correctly.

   So, it appears that fsck is attempting to determine a file
system type, tries to use /etc/fstab, and then falls back to
a secondary scheme. In the secondary scheme, ufs is what we want,
but vinum is what we're getting.

   If anyone has any information about this please let me know. I'll
try to look into it tomorrow.


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to