You wrote:

> For the last few days (not sure when it started) I've been unable to build
> -STABLE on a -CURRENT machine.  This has proven a problem for recent
> RELENG_3 MFC's of security fixes; I've tried upgrading to the most recent
> -CURRENT on the box, making sure /usr/include is updated, et al.  I'm
> guessing this is /usr/include pollution in the /usr/src build, but won't
> speculate too much more as I'm travelling tomorrow.  Attached below is the
> breakage from buildworld.

> cd /usr/src/share/syscons/scrnmaps; make build-tools
> cc -static -O -pipe   -I/usr/src/share/syscons/scrnmaps
> -DFIL=\"koi8-r2cp866\"  
>  -o /usr/src/share/syscons/scrnmaps/mkscrfil.c
> In file included from /usr/src/share/syscons/scrnmaps/mkscrfil.c:28:
> /usr/include/machine/console.h:3: #error "this file includes
> <machine/console.h>
>  which is deprecated, use <sys/{kb,cons,fb}io.h> instead"

I've seen the same thing.  I hacked up the -stable source to include the
correct -current include files to get past this, but that strikes me as
extremely non-optimal.  I tried hacking up the Makefile in 
/usr/src/share/syscons/scrnmaps to use a different include path, but don't
have the know-how or mojo to get that working.

Have you had any replies to this message or further insights? If so, I'd 
very much appreciate hearing them.

Thank you,


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to