I recently purchased a new Toshiba Satellite 2805 laptop, and I'm
trying to install -current on it =) When I tried to install from the
-current snapshots they all would lockup just after 'pcib0: ...' was
printed. So I tried a 4-stable snapshot and that worked
perfectly. However, I'm now trying to upgrade to -current, but it
still locks up in the kernel when trying to initialize the pci
bus. The following are the last lines of a verbose boot just before
it locks up:

pcib0: <Intel 82443BX (440 BX) host to PCI bridge> at pcibus 0 on
pci0: physical bus=0
      map[10]: type 3, range 32, base e00000000, size 27, enabled
found-> vendor=0x8086, dev=0x7190, revid=0x03
        bus=0, slot=0, func=0
        class=06-00-00, hdrtype=0x00, mfdev=0

( Then three more devices it finds, and then this is the last one:

found-> vendor=0x8086, dev=0x7112, revid=0x01
        bus=0, slot=5, func=2
        class=0c-03-00, hdrtype=0x00, mfdev=0
        intpin=d, irq=11

When looking at pciconf this last device is my USB UHCI controller,
but I don't have it in my kernel:

uhci0@pci0:5:2: class=0x0c0300 card=0x00000000 chip=0x71128086
rev=0x01 hdr=0x00

Now, when I recompile the kernel without `device pci' it boots fine
without any lockups. Is anyone else having similar problems? I looked
through the archives but couldn't find anyone else with similar
problems. It looks like it's been broken for awhile as I tried current
snapshots back to March 1, and they all locked up at the same
place. I'll be glad to try any patches to try and get this working.

The following is dmesg on a boot without `device pci':

Copyright (c) 1992-2001 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.0-CURRENT #2: Fri May 25 21:20:48 EDT 2001
    [EMAIL PROTECTED]:/usr/obj/usr/src/sys/SATELLITE
Timecounter "i8254"  frequency 1193182 Hz
Timecounter "TSC"  frequency 746338989 Hz
CPU: Pentium III/Pentium III Xeon/Celeron (746.34-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x686  Stepping = 6
real memory  = 134086656 (130944K bytes)
avail memory = 126726144 (123756K bytes)
Preloaded elf kernel "kernel" at 0xc03b2000.
Pentium Pro MTRR support enabled
npx0: <math processor> on motherboard
npx0: INT 16 interface
isa0: <ISA bus> on motherboard
sc0: <System console> on isa0
sc0: VGA <16 virtual consoles, flags=0x200>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ata0 at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0
ata1 at port 0x170-0x177,0x376 irq 15 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: Generic chipset (ECP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250
sio1: configured irq 3 not in bitmap of probed irqs 0
atspeaker0: <AT speaker> at port 0x61 on isa0
unknown: <PNP0303> can't assign resources
unknown: <PNP0f13> can't assign resources
unknown: <PNP0700> can't assign resources
unknown: <PNP0401> can't assign resources
IP Filter: v3.4.16 initialized.  Default = pass all, Logging = enabled
ata1-slave: ata_command: timeout waiting for intr
ata1-slave: identify failed
ad0: 19077MB <TOSHIBA MK2016GAP> [38760/16/63] at ata0-master BIOSPIO
acd0: DVD-ROM <UJDA540> at ata1-master BIOSPIO
Mounting root from ufs:/dev/ad0s2a

And here is my kernel config:
machine         i386
cpu             I686_CPU
ident           SATELLITE
maxusers        32
options         MATH_EMULATE            #Support for x87 emulation
options         INET                    #InterNETworking
options         FFS                     #Berkeley Fast Filesystem
options         SOFTUPDATES             #Enable FFS soft updates support
options         MFS                     #Memory Filesystem
options         MD_ROOT                 #MD is a potential root device
options         NFS                     #Network Filesystem
options         NFS_ROOT                #NFS usable as root device, NFS required
options         MSDOSFS                 #MSDOS Filesystem
options         CD9660                  #ISO 9660 Filesystem
options         PROCFS                  #Process filesystem
options         COMPAT_43               #Compatible with BSD 4.3 [KEEP THIS!]
options         UCONSOLE                #Allow users to grab the console
options         USERCONFIG              #boot -c editor
options         VISUAL_USERCONFIG       #visual boot -c editor
options         KTRACE                  #ktrace(1) support
options         SYSVSHM                 #SYSV-style shared memory
options         SYSVMSG                 #SYSV-style message queues
options         SYSVSEM                 #SYSV-style semaphores
options         P1003_1B                #Posix P1003_1B real-time extensions
options         KBD_INSTALL_CDEV        # install a CDEV entry in /dev
options         COMPAT_LINUX            # Linux stuff
device          isa
device          eisa
device          fdc
device          ata
device          atadisk                 # ATA disk drives
device          atapicd                 # ATAPI CDROM drives
device          atkbdc          # At keyboard controller
device          atkbd           # at keyboard
device          psm             # psm mouse
device          vga             # VGA screen
device          sc
device          npx
device          sio             # 8250, 16[45]50 based serial ports
device          ppc
device          ppbus           # Parallel port bus (required)
device          lpt             # Printer
device          random          # Entropy device
device          loop            # Network loopback
device          ether           # Ethernet support
device          tun             # Packet tunnel.
device          pty             # Pseudo-ttys (telnet etc)
device          md              # Memory "disks"
device          speaker
options         IPFILTER
options         IPFILTER_LOG
options         TCP_DROP_SYNFIN
device          bpf             # Berkeley packet filter
options         DDB
options         INVARIANTS
options         INVARIANT_SUPPORT
options         WITNESS

And the full pciconf is:

chip0@pci0:0:0: class=0x060000 card=0x00011179 chip=0x71908086
rev=0x03 hdr=0x00
pcib1@pci0:1:0: class=0x060400 card=0x00000000 chip=0x71918086
rev=0x03 hdr=0x01
isab0@pci0:5:0: class=0x068000 card=0x00000000 chip=0x71108086
rev=0x02 hdr=0x00
atapci0@pci0:5:1:       class=0x010180 card=0x00000000 chip=0x71118086
rev=0x01 hdr=0x00
uhci0@pci0:5:2: class=0x0c0300 card=0x00000000 chip=0x71128086
rev=0x01 hdr=0x00
chip1@pci0:5:3: class=0x068000 card=0x00000000 chip=0x71138086
rev=0x03 hdr=0x00
fxp0@pci0:8:0:  class=0x020000 card=0x24118086 chip=0x12298086
rev=0x09 hdr=0x00
none0@pci0:8:1: class=0x070002 card=0x24118086 chip=0x00d4115d
rev=0x00 hdr=0x00
chip2@pci0:11:0:        class=0x060700 card=0x00011179 chip=0x06171179
rev=0x20 hdr=0x02
chip3@pci0:11:1:        class=0x060700 card=0x00011179 chip=0x06171179
rev=0x20 hdr=0x02
none1@pci0:12:0:        class=0x040100 card=0x00011179 chip=0x00121073
rev=0x00 hdr=0x00
none2@pci1:0:0: class=0x030000 card=0x00011179 chip=0x8c125333
rev=0x13 hdr=0x00




  Mike Heffner               <[EMAIL PROTECTED]>
  Fredericksburg, VA       <[EMAIL PROTECTED]>

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to