This is on a system (my laptop):
FreeBSD localhost 5.0-CURRENT FreeBSD 5.0-CURRENT #13: Sun May 27 23:44:24 PDT 2001    
 [EMAIL PROTECTED]:/common/C/obj/usr/src/sys/LAPTOP_30W  i386 Mon May 28 
07:27:59 PDT 2001

Recent CVSup activity:
CVSup begin from at Sat May 26 03:47:01 PDT 2001
CVSup ended from at Sat May 26 03:52:48 PDT 2001
CVSup begin from at Sun May 27 03:47:01 PDT 2001
CVSup ended from at Sun May 27 03:53:36 PDT 2001
CVSup begin from at Mon May 28 03:47:00 PDT 2001
CVSup ended from at Mon May 28 03:53:51 PDT 2001

I had tried the buildworld within X (as had been my normal practice until
the recent difficulties with swap and/or VM), and the system re-booted
itself.  Got the well-discussed symptom of an active file system failing
fsck's check of primary vs. first alternate superblock, and after fsck
got finished with the file system, soft updates got turned off, so I turned
soft updates back on again.

Since I was in single-user mode anyhow, I mounted the necessary file
systems, issued a "swapon -a", and proceeded to re-try the "make
buildworld" (& friends) -- from within "script" (again, as I usually do).

Here's a transcript of the first & last parts of the typescript file:

Script started on Mon May 28 01:21:19 2001
# mount && cd /usr/src && uname -a && date && make buildworld && date && make kernel 
KERNCONF=LAPTOP_30W && date && make installworld && date && mergemaster && date && 
sync && df -k
/dev/ad0s3a on / (ufs, local, soft-updates)
devfs on /dev (devfs, local)
/dev/ad0s3e on /usr (ufs, local, soft-updates)
/dev/ad0s3g on /var (ufs, local, soft-updates)
procfs on /proc (procfs, local)
/dev/ad0s3h on /common (ufs, local, soft-updates)
FreeBSD  5.0-CURRENT FreeBSD 5.0-CURRENT #13: Sun May 27 23:44:24 PDT 2001     
[EMAIL PROTECTED]:/common/C/obj/usr/src/sys/LAPTOP_30W  i386
Mon May 28 01:22:06 PDT 2001

>>> Rebuilding the temporary build tree
rm -rf /usr/obj/usr/src/i386

... [elided -- dhw]

cc -pg -O -pipe  -I. -I/usr/src/lib/libncurses -I/usr/src/lib/libncurses/../../c
ontrib/ncurses/ncurses -I/usr/src/lib/libncurses/../../contrib/ncurses/include -
/usr/include  -c /usr/src/lib/libncurses/../../contrib/ncurses/ncurses/tinfo/get

And a hand-transcription of the panic (starting with the last command
shown on the console from the "make buildworld"):

cc -fpic -DPIC -O -pipe -I. -I/usr/src/lib/libncurses 
-I/usr/src/lib/libncurses/../../contrib/ncurses/include -Wall -DFREEBSD_NATIVE 
-DNDEBIG -DHAVE_CONFIG_H -DTERMIOS -i/usr/obj/usr/src/i386/usr/include -c lib_gen.c -o 
freeing uidinfo: uid=0, proccnt=33
kernel trap 12 with interrupts disabled
panic: blockable sleep lock (sleep mutex) Giant @/usr/src/sys/vm/vm_fault.c:213
Stopped at    Debugger+0x44: pushl     %ebx
db> trace
Debugger(c03a499b) at Debugger+0x44
panic(c03a75e0,c03a3820,c03cc4b4,c03c1d9b,d5) at panic+0x70
witness_lock(c047dda0,8,c03c1d9b,d5) at witness_lock+0x1b2
vm_fault(c04692ac,deadc000,1,0,0) at vm_fault+0xb2
trap_pfault(ce7f4e34,0,deadc2af,ce7ffa60,c0e4259c) at trap_pfault+0x5d0
trap(ce7f0018,c01f0010,c01f0010,4,c0e4259c) at trap+0x5d0
calltrap() at calltrap+0x5
--- trap 0xc, eip=0xc01d8cb6, esp=0xce7f4e74, ebp=0xce7f4e80 ---
uihold(c0e42580,c1ca3a68,c03a4235,0,98) at uihold+0x5f
crdup(c0e3d600, ce7ffb7c,ce7ffa60,2,c0445a00) at crdup+0x4c
access(ce7ffa60,ce7f4f80,806b240,806f080,805d1ce) at access+0x18
syscall(2f,2f,2f,805d1ce,806f080) at syscall+0x71d
syscall_with_err_pushed() at syscall_with_err_pushed+0x1b

In addition to the kernel.old (dated a few hours earlier the same day), I
have a saved kernel from 16 May (which is the one from which I had booted
in order to build the one from 23:50 (PDT) on 27 May, so I could try that.
Or I could try some other things, if that might help identify the problem.
I have not (yet) tried any of the posted experimental patches against
anything involving file systems, soft updates, swap, or VM.  (I do have
a small patch for keyboard control of the sound "mute" function, as well
as some bits & pieces of some of Doug Ambrisko's sys/dev/an patches.
However, the Cisco/Aironet card wasn't inserted at any point during the
boot that did the panic.)


David H. Wolfskill                              [EMAIL PROTECTED]
As a computing professional, I believe it would be unethical for me to
advise, recommend, or support the use (save possibly for personal
amusement) of any product that is or depends on any Microsoft product.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to